Fix for the AEM Developer tool issue – Eclipse Plugin

 

In the current version of AEM Plugin, there is a known issue while exporting a plugin created project into server. This has been fixed in the latest version of Sling IDE but the same is expected to be bundled with AEM plugin in its next release. Meanwhile to fix this issue, follow the below steps.

Step 1: Download the latest Sling IDE code from https://svn.apache.org/repos/asf/sling/trunk/tooling/ide/ . Build the above package and get ‘org.apache.sling.ide.p2update-1.0.3-SNAPSHOT.zip’ file

Or you can also download the same from here org.apache.sling.ide.p2update-1.0.3-SNAPSHOT.zip 

Step 2: Then open your eclipse, Click Help > Install New Software… > and click on ‘Add’

Instal_New_Software
Instal_New_Software

Step 3: Click on ‘Archive’ and select the zip file that is created manually and click ‘Ok’

Add_Archive
Add_Archive

Step 4: Select ‘Sling’ and Click ‘Next’, agree to the license terms and install

 

Install_Sling_IDE
Install_Sling_IDE

Once it’s installed successfully, restart the eclipse. Now Import and Export of AEM project into server will be successful

Click here to see how to create an AEM project from Eclipse

7 thoughts on “Fix for the AEM Developer tool issue – Eclipse Plugin

  1. Or you can also download the same from here org.apache.sling.ide.p2update-1.0.3-SNAPSHOT.zip

    Where can I get this file…..the link is no longer available

     

Leave a Reply

Your email address will not be published. Required fields are marked *